kryptonitewhite??
So I got on it today getting on the interstate, battery light came on, stayed on a few seconds then went off. Put it in neutral, reved it, nothing for a few seconds, stopped reving, light came on a few seconds. Pulled over, put DMM on front battery 14.18. Reved it up, droped to 13.2...stereo off. Checked rear batts, 14.18 running, dropped to 13.5 off, probably would have kept dropping slowly.

O'Reilley AGM in front, 2 large O'Reilley AGMs in back 100aH. Iraggi HO alt, the highest at idle lowest peak: 160-180 idle, 200-220 peak.
Quote 0 0
D-Bass
sounds like the alternator has issues
Quote 0 0
pimpin at my house
yup regulator in the alt...
Quote 0 0
Boogie Woogie
Quote:
originally posted by pimpinatmyhouse: yup regulator in the alt...
or you actually killed the alternator, cause if you rev up and the battery drops the alternator is doing absolutely nothing
Quote 0 0
kryptonitewhite??
I know Iraggi is revamping..think Ill have any luck calling?
Quote 0 0
kryptonitewhite??
I went to Van's today, the local rebuild shop. The guy took the big ass DMM to my battery to confirm the voltage drop, told me to pull it and bring it in for a real test, and get this ****: He told me not to add alts but add batteries! So yup, Ill go to Advanced and O'reilleys now

made a vid showing the drop on the van's voltmeter while driving. I dont hear any squeel, it happens even at low RPM...

Quote 0 0
kryptonitewhite??
Went and load tested the alt, only doing 99A (rated 160-200A @ idle 220 peak above 1500 RPM) and tested the batteries, theyre all good. Guess I gotta get ahold of Iraggi and see if it's a warranty issue. yay!
Quote 0 0
TeamSubGoPoof
Quote:
Originally posted by kryptonitewhite??:
I went to Van's today, the local rebuild shop. The guy took the big ass DMM to my battery to confirm the voltage drop, told me to pull it and bring it in for a real test, and get this ****: He told me not to add alts but add batteries! So yup, Ill go to Advanced and O'reilleys now

made a vid showing the drop on the van's voltmeter while driving. I dont hear any squeel, it happens even at low RPM...

Batteries give reserve, why do you think SPL vehicles have 100+ batteries and usually only 1 alt if they use an alt at all?
Quote 0 0
kryptonitewhite??
Quote:
Originally posted by TeamSubGoPoof:
Quote:
quote:
Originally posted by kryptonitewhite??:
I went to Van's today, the local rebuild shop. The guy took the big ass DMM to my battery to confirm the voltage drop, told me to pull it and bring it in for a real test, and get this ****: He told me not to add alts but add batteries! So yup, Ill go to Advanced and O'reilleys now

made a vid showing the drop on the van's voltmeter while driving. I dont hear any squeel, it happens even at low RPM...

Batteries give reserve, why do you think SPL vehicles have 100+ batteries and usually only 1 alt if they use an alt at all?
I thought SPL vehicles have as many alts as possible and batteries as well, since they pull so much current in a short amount of time they use up most of the storage but try to recharge as quick as possible.

I know they use battery chargers to help get back up so it doesnt kill the alts, or, dont use alts at all because recharging 100+ batteries would kill the alts... but Im not in SPL, I dont burp, I drive around...and my extention cord only gets me to the end of my block.
Quote 0 0
kryptonitewhite??
pulled the Iraggi today, was gonna drop the stock back in so I have a vehicle to drive till I get it repaired and order a 2nd alt. The stock one has been sitting on a shelf in the basement since I pulled it. it didnt get wet, but it's been humid. The damn thing rusted and I cant even spin the pulley! Now what the f do I do? I am stranded at home, cant get ahold of Iraggi.
Quote 0 0
TeamSubGoPoof
Quote:
Originally posted by kryptonitewhite??:
Quote:
quote:
Originally posted by TeamSubGoPoof:
Quote:
quote:
Originally posted by kryptonitewhite??:
I went to Van's today, the local rebuild shop. The guy took the big ass DMM to my battery to confirm the voltage drop, told me to pull it and bring it in for a real test, and get this ****: He told me not to add alts but add batteries! So yup, Ill go to Advanced and O'reilleys now

made a vid showing the drop on the van's voltmeter while driving. I dont hear any squeel, it happens even at low RPM...

Batteries give reserve, why do you think SPL vehicles have 100+ batteries and usually only 1 alt if they use an alt at all?
I thought SPL vehicles have as many alts as possible and batteries as well, since they pull so much current in a short amount of time they use up most of the storage but try to recharge as quick as possible.

I know they use battery chargers to help get back up so it doesnt kill the alts, or, dont use alts at all because recharging 100+ batteries would kill the alts... but Im not in SPL, I dont burp, I drive around...and my extention cord only gets me to the end of my block.
::sigh::

I forget you know more then everyone...do what you want
Quote 0 0
Contact Us | Legal Notices | Privacy