brown8269
I have two DD 2500 subwoofer on a memphis mc1500D amp. But something isn't right about the way it sound. What could be wrong.
Quote 0 0
Iggster
Subs are out of phase. Settings on the amp are off.
Quote 0 0
AQIntrepid
If they are brand new it will take awhile for them to break in and reach full potential.
Quote 0 0
C.A.R. AUDIO
Yep, You need to allow proper break in time on DD's, AQ's, American Bass, most dual spider subs will take a while to "loosen up" so don't give up on them. Ive seen too many people get rid of there "good" subs right away for this. Give em some time. You'll be happy you did.
Quote 0 0
swiss210
my sub sounded like **** as well when i had first got it played a low to high sweep for 28 hours on low volume sounded good, then get this i blew it a week later on 1,000 watts this sub is saposta be able to take 3k so i got a fresh recone and now its for sale 450 with box 400 with out it its the 2515
Quote 0 0
rowland
u can blow up a sub with 100 watts that has 3k rms easy just set the amp wrong and and turn head unit up past clipping signal for a while and she will blow
Quote 0 0
SoundCustoms
Quote:
Originally posted by swiss210:
my sub sounded like **** as well when i had first got it played a low to high sweep for 28 hours on low volume sounded good, then get this i blew it a week later on 1,000 watts this sub is saposta be able to take 3k so i got a fresh recone and now its for sale 450 with box 400 with out it its the 2515
No offence, but we need more people like you. You keep the industry going. Now...buy another brand, make another company happy... And maybe someday you will be happy. Good luck!
Quote 0 0
SoundCustoms
Quote:
Originally posted by brown8269@yahoo.com:
I have two DD 2500 subwoofer on a memphis mc1500D amp. But something isn't right about the way it sound. What could be wrong.
Can you be more specific?

HOW do they sound wrong?

What car, box specs, what source do you use (HU, etc.) ?
Quote 0 0
Glass City Sounds
i not sure about 100 watt but a 1000 all day
Quote 0 0
IceWaLL
Quote:
Originally posted by swiss210:
my sub sounded like **** as well when i had first got it played a low to high sweep for 28 hours on low volume sounded good, then get this i blew it a week later on 1,000 watts this sub is saposta be able to take 3k so i got a fresh recone and now its for sale 450 with box 400 with out it its the 2515
HAHAHAHA

clean signal would prevent that. Seen a friend blow up his 3515 on 1200 watts and he actually arc'd the wire going thru the spider. yet I was able to put 2400 thru it no problem SAME amps just 2 (amps) of them. (he wanted bass boost )


also keep in mind when you buy subs and they dont sound right (from a reputable company) there are usually only a few reasons: BOX is VERY important, signal coming to them, and install.... etc

I always check my signal coming to them then I ALWAYS ALWAYS ALWAYS check my box!!!!!
Quote 0 0
Contact Us | Legal Notices | Privacy